Upstream Cosmos environment provider incident

Incident Report for Augment Code

Resolved

This incident has been resolved.
Posted May 07, 2026 - 20:04 PDT

Monitoring

The provider has put in mitigations and services are returning to normal. We'll continue monitoring Cosmos as agents come back online.
Posted May 07, 2026 - 19:36 PDT

Update

Our provider is continuing to work on their mitigation. We will update the status as progress is made.
Posted May 07, 2026 - 18:21 PDT

Identified

The provider has acknowledged that they are having a problem and are working on mitigating the incident.
Posted May 07, 2026 - 17:44 PDT

Investigating

We are currently investigating an issue with our upstream provider failing to start Cosmos environments
Posted May 07, 2026 - 17:36 PDT