Augment service is experiencing higher rate of 500

Incident Report for Augment Code

Postmortem

Service Disruption on August 21 — What Happened

On August 21, between 12:12 and 13:40 PDT, some customers experienced failed Chat and Agent requests. A routine software update exposed a dormant bug in how certain conversation histories were processed, causing roughly 12% of conversations to return errors; new conversations were largely unaffected. We rolled back the update within the hour and deployed a permanent fix the same day.

Our internal review identified where our safeguards fell short, and our team is already putting in place a combination of agentic, programmatic, and human safeguards to ensure an issue like this cannot reach customers again.

We're sorry for the disruption, and we thank the customers who reported the issue. Please reach out to your account contact or support if you have questions.

Posted Aug 26, 2026 - 14:32 PDT

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 13:45 PDT

Monitoring

A fix has been deployed and issues should stop happening. We are seeing recovery of error rates.
Posted Aug 21, 2026 - 13:39 PDT

Identified

We have identified an issue that causing an elevated rate of 500s errors in all Augment agent surfaces, including Cosmos, CLI, and IDE extensions. The issue started around 12:15pm PDT today. We are working on mitigating the issue.
Posted Aug 21, 2026 - 13:15 PDT
This incident affected: Cosmos.